What’s Vulnerable › Vulnerabilities
CVE-2026-23902: Apache DolphinScheduler: Users are able to use tenants that are not defined on the platform during workflow execution.
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-24 · updated 2026-10-26
- Weakness: CWE-863
Description
Incorrect Authorization vulnerability in Apache DolphinScheduler allows authenticated users with system login permissions to use tenants that are not defined on the platform during workflow execution. This issue affects Apache DolphinScheduler versions prior to 3.4.1. Users are recommended to upgrade to version 3.4.1, which fixes this issue.
Affected products
- Apache Software Foundation Apache DolphinScheduler: before 3.4.1 — fixed in 3.4.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache DolphinScheduler 3.4.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/hy4ntb2gys8150zfmnxhsd5ph0hoh7s9
- http://www.openwall.com/lists/oss-security/2026/04/24/1
Get alerted when CVE-2026-23902 or the next vulnerability affects your stack