What’s Vulnerable › Vulnerabilities

CVE-2026-23928: Stored XSS vulnerability in the Item history/Plain text widget

Description

The Item history widget (in Zabbix 7.0+) or the Plain text widget (in Zabbix 6.0) can execute injected JavaScript when HTML display is enabled. This can allow an attacker to perform unauthorized actions depending on which user opens a dashboard containing these widgets. The malicious JavaScript would have to come from a monitored host controlled by the attacker. Note: the Item history widget is a replacement for the Plain text widget since Zabbix 7.0.

Affected products

How to fix

Upgrade to a fixed version: Zabbix 6.0.45, 7.0.24, 7.4.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-23928 or the next vulnerability affects your stack