What’s Vulnerable › Vulnerabilities
CVE-2026-23938: Server DoS via JavaScript preprocessing or script items
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-18 · updated 2026-09-23
- Weakness: CWE-248
Description
An authenticated administrator is able to crash Zabbix server or proxy by creating specifically crafted preprocessing/script item JavaScript scripts, leading to potential denial of service.
Affected products
- Zabbix: from 6.0.0 before 6.0.47; from 7.0.0 before 7.0.27; from 7.4.0 before 7.4.11 — fixed in 6.0.47, 7.0.27, 7.4.11
How to fix
Upgrade to a fixed version: Zabbix 6.0.47, 7.0.27, 7.4.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-23938 or the next vulnerability affects your stack