What’s Vulnerable › Vulnerabilities
CVE-2026-2394: Buffer Over-read vulnerability in RTI Connext Professional (Core Libraries) allows Overread Buffers.
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-01 · updated 2026-09-22
- Weakness: CWE-126
Description
Buffer Over-read vulnerability in RTI Connext Professional (Core Libraries) allows Overread Buffers. This issue affects Connext Professional: from 7.4.0 before 7.7.0, from 7.0.0 before 7.3.1.1, from 6.1.0 before 6.1.2.34, from 6.0.0 before 6.0.*, from 5.3.0 before 5.3.*, from 5.2.0 before 5.2.*, from 4.3x before 5.1.*.
Affected products
- RTI Connext Professional: from 4.3.0 through 5.2.3; from 5.3.0 through 5.3.1.45; from 6.0.0 through 6.0.1.40; from 6.1.0 through 6.1.2.27; from 7.0.0 before 7.3.1.1; from 7.4.0 before 7.7.0 — fixed in 7.3.1.1, 7.7.0
How to fix
Upgrade to a fixed version: RTI Connext Professional 7.3.1.1, 7.7.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-2394 or the next vulnerability affects your stack