What’s Vulnerable › Vulnerabilities
CVE-2026-23947: Orval MCP client is vulnerable to code injection via unsanitized x-enum-descriptions in enum generation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-20 · updated 2026-06-17
- Weakness: CWE-77
Description
Orval generates type-safe JS clients (TypeScript) from any valid OpenAPI v3 or Swagger v2 specification. Versions prior to 7.19.0 until 8.0.2 are vulnerable to arbitrary code execution in environments consuming generated clients. This issue is similar in nature to CVE-2026-22785, but affects a different code path in @orval/core that was not addressed by CVE-2026-22785's fix. The vulnerability allows untrusted OpenAPI specifications to inject arbitrary TypeScript/JavaScript code into generated clients via the x-enumDescriptions field, which is embedded without proper escaping in getEnumImplementation(). I have confirmed that the injection occurs during const enum generation and results in executable code within the generated schema files. Orval 7.19.0 and 8.0.2 contain a fix for the issue.
Affected products
- orval-labs orval: before 7.19.0; from 8.0.0 before 8.0.2 — fixed in 7.19.0, 8.0.2
How to fix
Upgrade to a fixed version: orval-labs orval 7.19.0, 8.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/orval-labs/orval/releases/tag/v8.0.2
- https://github.com/orval-labs/orval/security/advisories/GHSA-h526-wf6g-67jv
Get alerted when CVE-2026-23947 or the next vulnerability affects your stack