What’s Vulnerable › Vulnerabilities
CVE-2026-23957: seroval is vulnerable to Denial of Service via array serialization
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-22 · updated 2026-06-17
- Weakness: CWE-770
Description
seroval facilitates JS value stringification, including complex structures beyond JSON.stringify capabilities. In versions 1.4.0 and below, overriding encoded array lengths by replacing them with an excessively large value causes the deserialization process to significantly increase processing time. This issue has been fixed in version 1.4.1.
Affected products
- lxsmnsyc seroval: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: lxsmnsyc seroval 1.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/lxsmnsyc/seroval/commit/ce9408ebc87312fcad345a73c172212f2a798060
- https://github.com/lxsmnsyc/seroval/security/advisories/GHSA-66fc-rw6m-c2q6
Get alerted when CVE-2026-23957 or the next vulnerability affects your stack