What’s Vulnerable › Vulnerabilities

CVE-2026-23962: Mastodon vulnerable to Denial of Service from a single post (client/server)

Description

Mastodon is a free, open-source social network server based on ActivityPub. Mastodon versions before v4.3.18, v4.4.12, and v4.5.5 do not have a limit on the maximum number of poll options for remote posts, allowing attackers to create polls with a very large amount of options, greatly increasing resource consumption. Depending on the number of poll options, an attacker can cause disproportionate resource usage in both Mastodon servers and clients, potentially causing Denial of Service either server-side or client-side. Mastodon versions v4.5.5, v4.4.12, v4.3.18 are patched.

Affected products

How to fix

Upgrade to a fixed version: mastodon 4.3.18, 4.4.12, 4.5.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-23962 or the next vulnerability affects your stack