What’s Vulnerable › Vulnerabilities
CVE-2026-23969: Apache Superset: Exposure of Sensitive Information via Incomplete ClickHouse Function Filtering
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-89
Description
Apache Superset utilizes a configurable dictionary, DISALLOWED_SQL_FUNCTIONS, to restrict the execution of potentially sensitive SQL functions within SQL Lab and charts. While this feature included restrictions for engines like PostgreSQL, a vulnerability was reported where the default list for the ClickHouse engine was incomplete. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.
Affected products
- Apache Superset: before 4.1.2 — fixed in 4.1.2
How to fix
Upgrade to a fixed version: Apache Superset 4.1.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/2q22sp4oj3krcgdkxchhtht0vgwp2wnd
- http://www.openwall.com/lists/oss-security/2026/02/24/4
Get alerted when CVE-2026-23969 or the next vulnerability affects your stack