What’s Vulnerable › Vulnerabilities
CVE-2026-23980: Apache Superset: Improper Neutralization of Special Elements used in a SQL Command
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in a SQL Command ('SQL Injection') vulnerability in Apache Superset allows an authenticated user with read access to conduct error-based SQL injection via the sqlExpression or where parameters. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.
Affected products
- Apache Superset: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: Apache Superset 6.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/h4l02zw1pr2vywv0dc5zjn3grdcdhwf4
- http://www.openwall.com/lists/oss-security/2026/02/24/5
Get alerted when CVE-2026-23980 or the next vulnerability affects your stack