What’s Vulnerable › Vulnerabilities
CVE-2026-23982: Apache Superset: Improper Authorization in Dataset Creation Allows Access Control Bypass
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-863
Description
An Improper Authorization vulnerability exists in Apache Superset that allows a low-privileged user to bypass data access controls. When creating a dataset, Superset enforces permission checks to prevent users from querying unauthorized data. However, an authenticated attacker with permissions to write datasets and read charts can bypass these checks by overwriting the SQL query of an existing dataset. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.
Affected products
- Apache Superset: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: Apache Superset 6.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/9lvbzwkw4rxgdvbpfvnnnfcll92v75fp
- http://www.openwall.com/lists/oss-security/2026/02/24/6
Get alerted when CVE-2026-23982 or the next vulnerability affects your stack