What’s Vulnerable › Vulnerabilities
CVE-2026-23983: Apache Superset: Sensitive Data Exposure via REST API (disabled by default)
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-200
Description
A Sensitive Data Exposure vulnerability exists in Apache Superset allowing authenticated users to retrieve sensitive user information. The Tag endpoint (disabled by default) allows users to retrieve a list of objects associated with a specific tag. When these associated objects include Users, the API response improperly serializes and returns sensitive fields, including password hashes (pbkdf2), email addresses, and login statistics. This vulnerability allows authenticated users with low privileges (e.g., Gamma role) to view sensitive authentication data This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue or make sure TAGGING_SYSTEM is False (Apache Superset current default)
Affected products
- Apache Superset: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: Apache Superset 6.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/62mgbc5hc8026skp69kb6vqozj3pr5ww
- http://www.openwall.com/lists/oss-security/2026/02/24/7
Get alerted when CVE-2026-23983 or the next vulnerability affects your stack