What’s Vulnerable › Vulnerabilities
CVE-2026-23984: Apache Superset: SQLLab Read-Only Bypass on PostgreSQL
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-863
Description
An Improper Input Validation vulnerability exists in Apache Superset that allows an authenticated user with SQLLab access to bypass the read-only verification check when using a PostgreSQL database connection. While the system effectively blocks standard Data Manipulation Language (DML) statements (e.g., INSERT, UPDATE, DELETE) on read-only connections, it fails to detect them in specially crafted SQL statements. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.
Affected products
- Apache Superset: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: Apache Superset 6.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/72cmgxtvp9pclto4ln1chbs1227nwd26
- http://www.openwall.com/lists/oss-security/2026/02/24/8
Get alerted when CVE-2026-23984 or the next vulnerability affects your stack