What’s Vulnerable › Vulnerabilities
CVE-2026-23985: Apache Superset: Regular Expression Denial of Service (ReDoS) in SQL Parser
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-10-23
- Weakness: CWE-1333
Description
A Regular Expression Denial of Service (ReDoS) vulnerability exists in Apache Superset versions 1.5.0 through 5.0.0. The vulnerability is located in the sql_parse.py component, specifically within the SQL_REGEX used for parsing SQL statements in the sqlparse library integration. The affected regular expression contains overlapping disjunctions that share a common outer quantifier. An authenticated attacker can exploit this by sending a maliciously crafted input string (specifically a long sequence of backslashes or similar characters) to endpoints that process SQL queries This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue. Workarounds: ● WAF Rules: Implement Web Application Firewall (WAF) rules to detect and block requests containing excessively long sequences of backslashes or suspicious repeated patterns in the queries.extras.where parameter. ● Rate Limiting: Ensure strict rate limiting is applied to the /api/v1/chart/data endpoint to reduce the impact of potential attacks.
Affected products
- Apache Superset: from 1.5.0 before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: Apache Superset 6.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/fdy7tx7glv90ypd7qnm1g1pt7nn336qx
- http://www.openwall.com/lists/oss-security/2026/07/30/7
Get alerted when CVE-2026-23985 or the next vulnerability affects your stack