What’s Vulnerable › Vulnerabilities
CVE-2026-24001: jsdiff has a Denial of Service vulnerability in parsePatch and applyPatch
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-22 · updated 2026-07-15
- Weakness: CWE-400
Description
jsdiff is a JavaScript text differencing implementation. Prior to versions 8.0.3, 5.2.2, 4.0.4, and 3.5.1, attempting to parse a patch whose filename headers contain the line break characters `\r`, `\u2028`, or `\u2029` can cause the `parsePatch` method to enter an infinite loop. It then consumes memory without limit until the process crashes due to running out of memory. Applications are therefore likely to be vulnerable to a denial-of-service attack if they call `parsePatch` with a user-provided patch as input. A large payload is not needed to trigger the vulnerability, so size limits on user input do not provide any protection. Furthermore, some applications may be vulnerable even when calling `parsePatch` on a patch generated by the application itself if the user is nonetheless able to control the filename headers (e.g. by directly providing the filenames of the files to be diffed). The `applyPatch` method is similarly affected if (and only if) called with a string representation of a patch as an argument, since under the hood it parses that string using `parsePatch`. Other methods of the library are unaffected. Finally, a second and lesser interdependent bug - a ReDOS - also exhibits when those same line break characters are present in a patch's *patch* header (also known as its "leading garbage"). A maliciously-crafted patch header of length *n* can take `parsePatch` O(*n*³) time to parse. Versions 8.0.3, 5.2.2, 4.0.4, and 3.5.1 contain a fix. As a workaround, do not attempt to parse patches that contain any of these characters: `\r`, `\u2028`, or `\u2029`.
Affected products
- kpdecker jsdiff: before 3.5.1; from 4.0.0 before 4.0.4; from 5.0.0 before 5.2.2; from 6.0.0 before 8.0.3 — fixed in 3.5.1, 4.0.4, 5.2.2, 8.0.3
How to fix
Upgrade to a fixed version: kpdecker jsdiff 3.5.1, 4.0.4, 5.2.2, 8.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/kpdecker/jsdiff/commit/15a1585230748c8ae6f8274c202e0c87309142f5
- https://github.com/kpdecker/jsdiff/issues/653
- https://github.com/kpdecker/jsdiff/pull/649
- https://github.com/kpdecker/jsdiff/security/advisories/GHSA-73rr-hh4g-fpgx
- https://access.redhat.com/security/cve/CVE-2026-24001
- https://bugzilla.redhat.com/show_bug.cgi?id=2431930
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-24001.json
Get alerted when CVE-2026-24001 or the next vulnerability affects your stack