What’s Vulnerable › Vulnerabilities
CVE-2026-24009: Docling Core vulnerable to Remote Code Execution via unsafe PyYAML usage
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-22 · updated 2026-06-17
- Weakness: CWE-502
Description
Docling Core (or docling-core) is a library that defines core data types and transformations in the document processing application Docling. A PyYAML-related Remote Code Execution (RCE) vulnerability, namely CVE-2020-14343, is exposed in docling-core starting in version 2.21.0 and prior to version 2.48.4, specifically only if the application uses pyyaml prior to version 5.4 and invokes `docling_core.types.doc.DoclingDocument.load_from_yaml()` passing it untrusted YAML data. The vulnerability has been patched in docling-core version 2.48.4. The fix mitigates the issue by switching `PyYAML` deserialization from `yaml.FullLoader` to `yaml.SafeLoader`, ensuring that untrusted data cannot trigger code execution. Users who cannot immediately upgrade docling-core can alternatively ensure that the installed version of PyYAML is 5.4 or greater.
Affected products
- docling-project docling-core: from 2.21.0 before 2.48.4 — fixed in 2.48.4
How to fix
Upgrade to a fixed version: docling-project docling-core 2.48.4. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-8q59-q68h-6hv4
- https://github.com/docling-project/docling-core/commit/3e8d628eeeae50f0f8f239c8c7fea773d065d80c
- https://github.com/docling-project/docling-core/issues/482
- https://github.com/docling-project/docling-core/releases/tag/v2.48.4
- https://github.com/docling-project/docling-core/security/advisories/GHSA-vqxf-v2gg-x3hc
Get alerted when CVE-2026-24009 or the next vulnerability affects your stack