What’s Vulnerable › Vulnerabilities

CVE-2026-24015: Apache IoTDB: Insecure Default Configuration Vulnerability

Description

A vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7. Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache IoTDB 1.3.7, 2.0.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-24015 or the next vulnerability affects your stack