What’s Vulnerable › Vulnerabilities
CVE-2026-24048: Backstage has a Possible SSRF when reading from allowed URL's in `backend.reading.allow`
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-21 · updated 2026-06-17
- Weakness: CWE-918
Description
Backstage is an open framework for building developer portals, and @backstage/backend-defaults provides the default implementations and setup for a standard Backstage backend app. Prior to versions 0.12.2, 0.13.2, 0.14.1, and 0.15.0, the `FetchUrlReader` component, used by the catalog and other plugins to fetch content from URLs, followed HTTP redirects automatically. This allowed an attacker who controls a host listed in `backend.reading.allow` to redirect requests to internal or sensitive URLs that are not on the allowlist, bypassing the URL allowlist security control. This is a Server-Side Request Forgery (SSRF) vulnerability that could allow access to internal resources, but it does not allow attackers to include additional request headers. This vulnerability is fixed in `@backstage/backend-defaults` version 0.12.2, 0.13.2, 0.14.1, and 0.15.0. Users should upgrade to this version or later. Some workarounds are available. Restrict `backend.reading.allow` to only trusted hosts that you control and that do not issue redirects, ensure allowed hosts do not have open redirect vulnerabilities, and/or use network-level controls to block access from Backstage to sensitive internal endpoints.
Affected products
- Linuxfoundation Backstage/Backend Defaults: before 0.12.2; from 0.13.0 through 0.13.2; from 0.14.0 through 0.14.1 — fixed in 0.12.2
How to fix
Upgrade to a fixed version: Linuxfoundation Backstage/Backend Defaults 0.12.2. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/27f9061d24affd1b9212fe0abd476bfc3fbaedcb
- https://github.com/backstage/backstage/security/advisories/GHSA-q2x5-4xjx-c6p9
Get alerted when CVE-2026-24048 or the next vulnerability affects your stack