What’s Vulnerable › Vulnerabilities
CVE-2026-24055: Langfuse Slack OAuth Installation Endpoint Lacks Authentication, Enabling Arbitrary Project Linking
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-22 · updated 2026-06-17
- Weakness: CWE-284
Description
Langfuse is an open source large language model engineering platform. In versions 3.146.0 and below, the /api/public/slack/install endpoint initiates Slack OAuth using a projectId provided by the client without authentication or authorization. The projectId is preserved throughout the OAuth flow, and the callback stores installations based on this untrusted metadata. This allows an attacker to bind their Slack workspace to any project and potentially receive changes to prompts stored in Langfuse Prompt Management. An attacker can replace existing Prompt Slack Automation integrations or pre-register a malicious one, though the latter requires an authenticated user to unknowingly configure it despite visible workspace and channel indicators in the UI. This issue has been fixed in version 3.147.0.
Affected products
- langfuse: from 3.89.0 before 3.147.0 — fixed in 3.147.0
How to fix
Upgrade to a fixed version: langfuse 3.147.0. Check the vendor advisory for mitigations.
References
- https://github.com/langfuse/langfuse/commit/3adc89e4d72729eabef55e46888b8ce80a7e3b0a
- https://github.com/langfuse/langfuse/releases/tag/v3.147.0
- https://github.com/langfuse/langfuse/security/advisories/GHSA-pvq7-vvfj-p98x
- https://langfuse.com/docs/prompt-management/features/webhooks-slack-integrations
Get alerted when CVE-2026-24055 or the next vulnerability affects your stack