What’s Vulnerable › Vulnerabilities
CVE-2026-24056: pnpm has symlink traversal in file:/git dependencies
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-26 · updated 2026-06-17
- Weakness: CWE-22
Description
pnpm is a package manager. Prior to version 10.28.2, when pnpm installs a `file:` (directory) or `git:` dependency, it follows symlinks and reads their target contents without constraining them to the package root. A malicious package containing a symlink to an absolute path (e.g., `/etc/passwd`, `~/.ssh/id_rsa`) causes pnpm to copy that file's contents into `node_modules`, leaking local data. The vulnerability only affects `file:` and `git:` dependencies. Registry packages (npm) have symlinks stripped during publish and are NOT affected. The issue impacts developers installing local/file dependencies andCI/CD pipelines installing git dependencies. It can lead to credential theft via symlinks to `~/.aws/credentials`, `~/.npmrc`, `~/.ssh/id_rsa`. Version 10.28.2 contains a patch.
Affected products
- pnpm: before 10.28.2 — fixed in 10.28.2
How to fix
Upgrade to a fixed version: pnpm 10.28.2. Check the vendor advisory for mitigations.
References
- https://github.com/pnpm/pnpm/commit/b277b45bc35ae77ca72d7634d144bbd58a48b70f
- https://github.com/pnpm/pnpm/releases/tag/v10.28.2
- https://github.com/pnpm/pnpm/security/advisories/GHSA-m733-5w8f-5ggw
Get alerted when CVE-2026-24056 or the next vulnerability affects your stack