What’s Vulnerable › Vulnerabilities
CVE-2026-24098: Apache Airflow: Assigning single DAG permission leaked all DAGs Import Errors
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-09 · updated 2026-06-17
- Weakness: CWE-200
Description
Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this issue
Affected products
- Apache Airflow: from 3.0.0 before 3.1.7 — fixed in 3.1.7
How to fix
Upgrade to a fixed version: Apache Airflow 3.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/60801
- https://lists.apache.org/thread/nx96435v77xdst7ls5lk57kqvqyj095x
- http://www.openwall.com/lists/oss-security/2026/02/09/3
Get alerted when CVE-2026-24098 or the next vulnerability affects your stack