What’s Vulnerable › Vulnerabilities
CVE-2026-24128: XWiki Affected by Reflected Cross-Site Scripting (XSS) in Error Messages
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-24 · updated 2026-06-17
- Weakness: CWE-79
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Versions 7.0-milestone-2 through 16.10.11, 17.0.0-rc-1 through 17.4.4, and 17.5.0-rc-1 through 17.7.0 contain a reflected Cross-site Scripting (XSS) vulnerability, which allows an attacker to craft a malicious URL and execute arbitrary actions with the same privileges as the victim. If the victim has administrative or programming rights, those rights can be exploited to gain full access to the XWiki installation. This issue has been patched in versions 17.8.0-rc-1, 17.4.5 and 16.10.12. To workaround, the patch can be applied manually, only a single line in templates/logging_macros.vm needs to be changed, no restart is required.
Affected products
- xwiki-platform: from 7.0.1 before 16.10.12; from 17.0.1 before 17.4.5; from 17.6.0 before 17.8.0; 7.0-milestone2, 7.0-rc1, 17.0.0-rc1 — fixed in 16.10.12, 17.4.5, 17.8.0
- xwiki-rendering: 17.5.0-rc1
How to fix
Upgrade to a fixed version: xwiki-platform 16.10.12, 17.4.5, 17.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/8337ac8c3b19c37f306723b638b2cae8b0a57dbf
- https://github.com/xwiki/xwiki-platform/releases/tag/xwiki-platform-16.10.12
- https://github.com/xwiki/xwiki-platform/releases/tag/xwiki-platform-17.4.5
- https://github.com/xwiki/xwiki-platform/releases/tag/xwiki-platform-17.8.0-rc-1
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-wvqx-m5px-6cmp
- https://jira.xwiki.org/browse/XWIKI-23462
Get alerted when CVE-2026-24128 or the next vulnerability affects your stack