What’s Vulnerable › Vulnerabilities
CVE-2026-24129: Runtipi is Vulnerable to Authenticated Arbitrary Remote Code Execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-22 · updated 2026-06-17
- Weakness: CWE-78
Description
Runtipi is a Docker-based, personal homeserver orchestrator that facilitates multiple services on a single server. Versions 3.7.0 and above allow an authenticated user to execute arbitrary system commands on the host server by injecting shell metacharacters into backup filenames. The BackupManager fails to sanitize the filenames of uploaded backups. The system persists user-uploaded files directly to the host filesystem using the raw originalname provided in the request. This allows an attacker to stage a file containing shell metacharacters (e.g., $(id).tar.gz) at a predictable path, which is later referenced during the restore process. The successful storage of the file is what allows the subsequent restore command to reference and execute it. This issue has been fixed in version 4.7.0.
Affected products
- runtipi: from 3.7.0 before 4.7.0 — fixed in 4.7.0
How to fix
Upgrade to a fixed version: runtipi 4.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/runtipi/runtipi/commit/c3aa948885554a370d374692158a3bfe1cfdc85a
- https://github.com/runtipi/runtipi/releases/tag/v4.7.0
- https://github.com/runtipi/runtipi/security/advisories/GHSA-vrgf-rcj5-6gv9
Get alerted when CVE-2026-24129 or the next vulnerability affects your stack