What’s Vulnerable › Vulnerabilities
CVE-2026-24130: Moonraker with LDAP Enabled Allows Malicious Search Filter Injection
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-22 · updated 2026-06-17
- Weakness: CWE-90
Description
Moonraker is a Python web server providing API access to Klipper 3D printing firmware. In versions 0.9.3 and below, instances configured with the "ldap" component enabled are vulnerable to LDAP search filter injection techniques via the login endpoint. The 401 error response message can be used to determine whether or not a search was successful, allowing for brute force methods to discover LDAP entries on the server such as user IDs and user attributes. This issue has been fixed in version 0.10.0.
Affected products
- Arksine moonraker: before 0.10.0 — fixed in 0.10.0
How to fix
Upgrade to a fixed version: Arksine moonraker 0.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/Arksine/moonraker/commit/74c5d8e44c4a4abbfbb06fb991e7ebb9ac947f42
- https://github.com/Arksine/moonraker/security/advisories/GHSA-3jqf-v4mv-747g
Get alerted when CVE-2026-24130 or the next vulnerability affects your stack