What’s Vulnerable › Vulnerabilities
CVE-2026-24135: Gogs vulnerable to arbitrary file deletion via path traversal in wiki page update
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-06 · updated 2026-06-17
- Weakness: CWE-22
Description
Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, a path traversal vulnerability exists in the updateWikiPage function of Gogs. The vulnerability allows an authenticated user with write access to a repository's wiki to delete arbitrary files on the server by manipulating the old_title parameter in the wiki editing form. This issue has been patched in versions 0.13.4 and 0.14.0+dev.
Affected products
- gogs: before 0.13.4 — fixed in 0.13.4
How to fix
Upgrade to a fixed version: gogs 0.13.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-24135 or the next vulnerability affects your stack