What’s Vulnerable › Vulnerabilities
CVE-2026-24308: Apache ZooKeeper: Sensitive information disclosure in client configuration handling
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-07 · updated 2026-07-15
- Weakness: CWE-532
Description
Improper handling of configuration values in ZKConfig in Apache ZooKeeper 3.8.5 and 3.9.4 on all platforms allows an attacker to expose sensitive information stored in client configuration in the client's logfile. Configuration values are exposed at INFO level logging rendering potential production systems affected by the issue. Users are recommended to upgrade to version 3.8.6 or 3.9.5 which fixes this issue.
Affected products
- Apache Software Foundation Apache ZooKeeper: from 3.8.0 before 3.8.6; from 3.9.0 before 3.9.5 — fixed in 3.8.6, 3.9.5
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache ZooKeeper 3.8.6, 3.9.5. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/qng3rtzv2pqkmko4rhv85jfplkyrgqdr
- http://www.openwall.com/lists/oss-security/2026/03/07/5
- https://access.redhat.com/errata/RHSA-2026:10184
- https://access.redhat.com/errata/RHSA-2026:14272
- https://access.redhat.com/errata/RHSA-2026:14276
- https://access.redhat.com/errata/RHSA-2026:34608
- https://access.redhat.com/errata/RHSA-2026:8509
- https://access.redhat.com/security/cve/CVE-2026-24308
- https://bugzilla.redhat.com/show_bug.cgi?id=2445451
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-24308.json
Get alerted when CVE-2026-24308 or the next vulnerability affects your stack