What’s Vulnerable › Vulnerabilities
CVE-2026-24399: ChatterMate has Stored Cross-Site Scripting (XSS) via Chatbot Input Execution
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-24 · updated 2026-06-17
- Weakness: CWE-79
Description
ChatterMate is a no-code AI chatbot agent framework. In versions 1.0.8 and below, the chatbot accepts and executes malicious HTML/JavaScript payloads when supplied as chat input. Specifically, an <iframe> payload containing a javascript: URI can be processed and executed in the browser context. This allows access to sensitive client-side data such as localStorage tokens and cookies, resulting in client-side injection. This issue has been fixed in version 1.0.9.
Affected products
- chattermate.chat: before 1.0.9 — fixed in 1.0.9
How to fix
Upgrade to a fixed version: chattermate.chat 1.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/chattermate/chattermate.chat/commit/ff3398031abb97ae28546eaf993fed3619eaffdd
- https://github.com/chattermate/chattermate.chat/releases/tag/v1.0.9
- https://github.com/chattermate/chattermate.chat/security/advisories/GHSA-72p3-w95w-q3j4
Get alerted when CVE-2026-24399 or the next vulnerability affects your stack