What’s Vulnerable › Vulnerabilities
CVE-2026-24413: Icinga has insecure permission of %ProgramData%\icinga2\var on Windows
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-29 · updated 2026-06-17
- Weakness: CWE-276
Description
Icinga 2 is an open source monitoring system. Starting in version 2.3.0 and prior to versions 2.13.14, 2.14.8, and 2.15.2, the Icinga 2 MSI did not set appropriate permissions for the `%ProgramData%\icinga2\var` folder on Windows. This resulted in the its contents - including the private key of the user and synced configuration - being readable by all local users. All installations on Windows are affected. Versions 2.13.14, 2.14.8, and 2.15.2 contains a fix. There are two possibilities to work around the issue without upgrading Icinga 2. Upgrade Icinga for Windows to at least version v1.13.4, v1.12.4, or v1.11.2. These version will automatically fix the ACLs for the Icinga 2 agent as well. Alternatively, manually update the ACL for the given folder `C:\ProgramData\icinga2\var` (and `C:\Program Files\WindowsPowerShell\modules\icinga-powershell-framework\certificate` to fix the issue for the Icinga for Windows as well) including every sub-folder and item to restrict access for general users, only allowing the Icinga service user and administrators access.
Affected products
- icinga2: from 2.3.0 before 2.13.14; from 2.14.0 before 2.14.8; from 2.15.0 before 2.15.2 — fixed in 2.13.14, 2.14.8, 2.15.2
How to fix
Upgrade to a fixed version: icinga2 2.13.14, 2.14.8, 2.15.2. Check the vendor advisory for mitigations.
References
- https://github.com/Icinga/icinga-powershell-framework/security/advisories/GHSA-88h5-rrm6-5973
- https://github.com/Icinga/icinga2/security/advisories/GHSA-vfjg-6fpv-4mmr
- https://icinga.com/blog/releasing-icinga-2-v2-15-2-v2-14-8-v2-13-14-and-icinga-for-windows-v1-13-4-v1-12-4-v1-11-2
Get alerted when CVE-2026-24413 or the next vulnerability affects your stack