What’s Vulnerable › Vulnerabilities
CVE-2026-24421: phpMyFAQ missing authorization exposes /api/setup/backup to any authenticated user
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-24 · updated 2026-06-17
- Weakness: CWE-862
Description
phpMyFAQ is an open source FAQ web application. Versions 4.0.16 and below have flawed authorization logic which exposes the /api/setup/backup endpoint to any authenticated user despite their permissions. SetupController.php uses userIsAuthenticated() but does not verify that the requester has configuration/admin permissions. Non-admin users can trigger a configuration backup and retrieve its path. The endpoint only checks authentication, not authorization, and returns a link to the generated ZIP. This issue is fixed in version 4.0.17.
Affected products
- thorsten phpMyFAQ: before 4.0.17 — fixed in 4.0.17
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.0.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-24421 or the next vulnerability affects your stack