What’s Vulnerable › Vulnerabilities

CVE-2026-2462: Admin RCE via Malicious Plugin Upload on CI Test Instances

Description

Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, 10.11.x <= 10.11.10 fail to restrict plugin installation on CI test instances with default admin credentials which allows an unauthenticated attacker to achieve remote code execution and exfiltrate sensitive configuration data including AWS and SMTP credentials via uploading a malicious plugin after changing the import directory. Mattermost Advisory ID: MMSA-2025-00528

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.11, 11.2.3, 11.3.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-2462 or the next vulnerability affects your stack