What’s Vulnerable › Vulnerabilities
CVE-2026-24640
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-121
Description
A Stack-based Buffer Overflow vulnerability [CWE-121] vulnerability in Fortinet FortiWeb 8.0.0 through 8.0.2, FortiWeb 7.6.0 through 7.6.6, FortiWeb 7.4 all versions, FortiWeb 7.2 all versions, FortiWeb 7.0.2 through 7.0.12 may allow a remote authenticated attacker who can bypass stack protection and ASLR to execute arbitrary code or commands via crafted HTTP requests.
Affected products
- Fortinet FortiWeb: from 7.0.2 through 7.0.12; from 7.2.0 before 7.6.7; from 8.0.0 before 8.0.3 — fixed in 7.6.7, 8.0.3
How to fix
Upgrade to a fixed version: Fortinet FortiWeb 7.6.7, 8.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-24640 or the next vulnerability affects your stack