What’s Vulnerable › Vulnerabilities
CVE-2026-2467: Heap-based Buffer Overflow vulnerability in RTI Connext Professional (Core Libraries) allows Overflow Variables and Tags.
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-17 · updated 2026-10-26
- Weakness: CWE-122
Description
Heap-based Buffer Overflow vulnerability in RTI Connext Professional (Core Libraries) allows Overflow Variables and Tags. This issue affects Connext Professional: from 7.4.0 before 7.7.0, from 7.0.0 before 7.3.1.3, from 6.1.0 before 6.1.*, from 6.0.0 before 6.0.*, from 5.3.0 before 5.3.*, from 5.2.0 before 5.2.*, from 5.0.0 before 5.1.*.
Affected products
- RTI Connext Professional: from 5.3.0 before 7.7.0 — fixed in 7.7.0
How to fix
Upgrade to a fixed version: RTI Connext Professional 7.7.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-2467 or the next vulnerability affects your stack