What’s Vulnerable › Vulnerabilities
CVE-2026-24671: Open eClass is Vulnerable to Stored Cross-Site Scripting (XSS) in Multiple High-Privilege User Fields
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The Open eClass platform (formerly known as GUnet eClass) is a complete course management system. Prior to version 4.2, a Stored Cross-Site Scripting (XSS) vulnerability allows authenticated high-privileged users (teachers or administrators) to inject malicious JavaScript into multiple user-controllable input fields across the application, which is executed when other users access affected pages. This issue has been patched in version 4.2.
Affected products
- gunet openeclass: before 4.2 — fixed in 4.2
How to fix
Upgrade to a fixed version: gunet openeclass 4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-24671 or the next vulnerability affects your stack