What’s Vulnerable › Vulnerabilities
CVE-2026-2469
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-14 · updated 2026-06-17
- Weakness: CWE-74
Description
Versions of the package directorytree/imapengine before 1.22.3 are vulnerable to Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') via the id() function in ImapConnection.php due to improperly escaping user input before including it in IMAP ID commands. This allows attackers to read or delete victim's emails, terminate the victim's session or execute any valid IMAP command on victim's mailbox by including quote characters " or CRLF sequences \r\n in the input.
Affected products
- directorytree/imapengine: before 1.22.3 — fixed in 1.22.3
How to fix
Upgrade to a fixed version: directorytree/imapengine 1.22.3. Check the vendor advisory for mitigations.
References
- https://gist.github.com/wanamirulhakim/74b41589cdea3c07c3375e5946960778
- https://github.com/DirectoryTree/ImapEngine/commit/87fca56affd9527e6907a705e6d600c5174d9a5a
- https://github.com/DirectoryTree/ImapEngine/pull/150
- https://security.snyk.io/vuln/SNYK-PHP-DIRECTORYTREEIMAPENGINE-15274300
Get alerted when CVE-2026-2469 or the next vulnerability affects your stack