What’s Vulnerable › Vulnerabilities
CVE-2026-24690: Gitea pull-request branch updates use insufficient permission checks
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-03 · updated 2026-10-25
- Weakness: CWE-284
Description
Gitea versions before 1.25.5 have insufficient permission checks for updating or rebasing pull request branches.
Affected products
- Gitea Open Source Git Server: before 1.25.5 — fixed in 1.25.5
How to fix
Upgrade to a fixed version: Gitea Open Source Git Server 1.25.5. Check the vendor advisory for mitigations.
References
- https://blog.gitea.com/release-of-1.25.5/
- https://github.com/go-gitea/gitea/pull/36465
- https://github.com/go-gitea/gitea/pull/36838
- https://github.com/go-gitea/gitea/releases/tag/v1.25.5
Get alerted when CVE-2026-24690 or the next vulnerability affects your stack