What’s Vulnerable › Vulnerabilities

CVE-2026-24692: Guest users can bypass read permissions via search API

Description

Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, 10.11.x <= 10.11.10 fail to properly enforce read permissions in search API endpoints which allows guest users without read permissions to access posts and files in channels via search API requests. Mattermost Advisory ID: MMSA-2025-00554

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.11, 11.2.3, 11.3.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-24692 or the next vulnerability affects your stack