What’s Vulnerable › Vulnerabilities
CVE-2026-24713: Apache IoTDB: JEXL Expression Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-09 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7. Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
Affected products
- Apache Software Foundation Apache IoTDB: from 1.0.0 before 1.3.7; from 2.0.0 before 2.0.7 — fixed in 1.3.7, 2.0.7
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache IoTDB 1.3.7, 2.0.7. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/vopgv6y2ccw403b0zv7rvojjrh7x1j5p
- http://www.openwall.com/lists/oss-security/2026/03/09/4
Get alerted when CVE-2026-24713 or the next vulnerability affects your stack