What’s Vulnerable › Vulnerabilities
CVE-2026-24734: Apache Tomcat Native, Apache Tomcat: OCSP revocation bypass
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-17 · updated 2026-07-15
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native: from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114. The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected. Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue. Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.
Affected products
- Apache Tomcat: from 9.0.83 before 9.0.115; from 10.1.1 before 10.1.52; from 11.0.1 before 11.0.18; 10.1.0-milestone1, 10.1.0-milestone10, 10.1.0-milestone11, 10.1.0-milestone12, 10.1.0-milestone13, 10.1.0-milestone14 (+40) — fixed in 10.1.52, 11.0.18, 9.0.115
- Apache Software Foundation Apache Tomcat Native: from 1.3.0 before 1.3.5; from 2.0.0 before 2.0.12 — fixed in 1.3.5, 2.0.12
How to fix
Upgrade to a fixed version: Apache Tomcat 10.1.52, 11.0.18, 9.0.115; Apache Software Foundation Apache Tomcat Native 1.3.5, 2.0.12. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/292dlmx3fz1888v6v16221kpozq56gml
- https://access.redhat.com/errata/RHSA-2026:19054
- https://access.redhat.com/errata/RHSA-2026:26323
- https://access.redhat.com/errata/RHSA-2026:36790
- https://access.redhat.com/errata/RHSA-2026:5611
- https://access.redhat.com/errata/RHSA-2026:5612
- https://access.redhat.com/errata/RHSA-2026:6569
- https://access.redhat.com/errata/RHSA-2026:8334
- https://access.redhat.com/security/cve/CVE-2026-24734
- https://bugzilla.redhat.com/show_bug.cgi?id=2440426
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-24734.json
Get alerted when CVE-2026-24734 or the next vulnerability affects your stack