What’s Vulnerable › Vulnerabilities
CVE-2026-24735: Apache Answer: Revision API Improper Access Control leads to Information Disclosure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-04 · updated 2026-06-17
- Weakness: CWE-359
Description
Exposure of Private Personal Information to an Unauthorized Actor vulnerability in Apache Answer. This issue affects Apache Answer: through 1.7.1. An unauthenticated API endpoint incorrectly exposes full revision history for deleted content. This allows unauthorized user to retrieve restricted or sensitive information. Users are recommended to upgrade to version 2.0.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Answer: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Answer 2.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/whxloom7mpxlyt5wzdskflsg5mzdzd60
- http://www.openwall.com/lists/oss-security/2026/02/04/1
Get alerted when CVE-2026-24735 or the next vulnerability affects your stack