What’s Vulnerable › Vulnerabilities
CVE-2026-24747: PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-27 · updated 2026-07-15
- Weakness: CWE-94
Description
PyTorch is a Python package that provides tensor computation. Prior to version 2.10.0, a vulnerability in PyTorch's `weights_only` unpickler allows an attacker to craft a malicious checkpoint file (`.pth`) that, when loaded with `torch.load(..., weights_only=True)`, can corrupt memory and potentially lead to arbitrary code execution. Version 2.10.0 fixes the issue.
Affected products
- PyTorch: before 2.10.0 — fixed in 2.10.0
How to fix
Upgrade to a fixed version: PyTorch 2.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/pytorch/pytorch/163122/commit/954dc5183ee9205cbe79876ad05dd2d9ae752139
- https://github.com/pytorch/pytorch/issues/163105
- https://github.com/pytorch/pytorch/releases/tag/v2.10.0
- https://github.com/pytorch/pytorch/security/advisories/GHSA-63cw-57p8-fm3p
- https://access.redhat.com/errata/RHSA-2026:24977
- https://access.redhat.com/security/cve/CVE-2026-24747
- https://bugzilla.redhat.com/show_bug.cgi?id=2433612
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-24747.json
Get alerted when CVE-2026-24747 or the next vulnerability affects your stack