What’s Vulnerable › Vulnerabilities
CVE-2026-24750: Kiteworks Secure Data Forms vulnerable to Cross-site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Kiteworks is a private data network (PDN). In Kiteworks Secure Data Forms prior to version 9.2.1, an authenticated attacker could exploit an Improper Neutralization of Input During Web Page Generation as Stored XSS when modifying forms. Upgrade Kiteworks to version 9.2.1 or later to receive a patch.
Affected products
- Kiteworks Email Protection Gateway: before 9.2.1 — fixed in 9.2.1
How to fix
Upgrade to a fixed version: Kiteworks Email Protection Gateway 9.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-24750 or the next vulnerability affects your stack