What’s Vulnerable › Vulnerabilities
CVE-2026-24754: Kiteworks Secure Data Forms Vulnerable to Cross-site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-01 · updated 2026-07-22
- Weakness: CWE-79
Description
Kiteworks is a private data network (PDN). Prior to version 9.3.0, a stored XSS vulnerability in Kiteworks Secure Data Forms could allow an authenticated attacker to execute arbitrary JavaScript code in other users' sessions. Upgrade Kiteworks to version 9.3.0 or later to receive a patch.
Affected products
- Kiteworks Email Protection Gateway: before 9.3.0 — fixed in 9.3.0
How to fix
Upgrade to a fixed version: Kiteworks Email Protection Gateway 9.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-24754 or the next vulnerability affects your stack