What’s Vulnerable › Vulnerabilities
CVE-2026-24771: Hono has a Cross-site Scripting vulnerability
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Hono is a Web application framework that provides support for any JavaScript runtime. Prior to version 4.11.7, a Cross-Site Scripting (XSS) vulnerability exists in the `ErrorBoundary` component of the hono/jsx library. Under certain usage patterns, untrusted user-controlled strings may be rendered as raw HTML, allowing arbitrary script execution in the victim's browser. Version 4.11.7 patches the issue.
Affected products
- honojs hono: before 4.11.7 — fixed in 4.11.7
How to fix
Upgrade to a fixed version: honojs hono 4.11.7. Check the vendor advisory for mitigations.
References
- https://github.com/honojs/hono/commit/2cf60046d730df9fd0aba85178f3ecfe8212d990
- https://github.com/honojs/hono/security/advisories/GHSA-9r54-q6cx-xmh5
Get alerted when CVE-2026-24771 or the next vulnerability affects your stack