What’s Vulnerable › Vulnerabilities

CVE-2026-24778: Ghost vulnerable to XSS via malicious Portal preview links

Description

Ghost is an open source content management system. In Ghost versions 5.43.0 through 5.12.04 and 6.0.0 through 6.14.0, an attacker was able to craft a malicious link that, when accessed by an authenticated staff user or member, would execute JavaScript with the victim's permissions, potentially leading to account takeover. Ghost Portal versions 2.29.1 through 2.51.4 and 2.52.0 through 2.57.0 were vulnerable to this issue. Ghost automatically loads the latest patch of the members Portal component via CDN. For Ghost 5.x users, upgrading to v5.121.0 or later fixes the vulnerability. v5.121.0 loads Portal v2.51.5, which contains the patch. For Ghost 6.x users, upgrading to v6.15.0 or later fixes the vulnerability. v6.15.0 loads Portal v2.57.1, which contains the patch. For Ghost installations using a customized or self-hosted version of Portal, it will be necessary to manually rebuild from or update to the latest patch version.

Affected products

How to fix

Upgrade to a fixed version: TryGhost Ghost 5.121.0, 6.15.0; Ghost Portal 2.51.5, 2.57.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-24778 or the next vulnerability affects your stack