What’s Vulnerable › Vulnerabilities

CVE-2026-24784: DotNetNuke.Core has a potential XSS vulnerability in modules' header and footer

Description

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Starting in version 9.0.0 and prior to versions 9.13.10 and 10.2.0, a content editor could inject scripts in module headers/footers that would run for other users. Versions 9.13.10 and 10.2.0 contain a fix for the issue.

Affected products

How to fix

Upgrade to a fixed version: DotNetNuke CMS Fixed in 9.1.1 10.2.0, 9.13.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-24784 or the next vulnerability affects your stack