What’s Vulnerable › Vulnerabilities
CVE-2026-24833: DotNetNuke.Core Vulnerable to Stored XSS in Module Description
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-28 · updated 2026-06-17
- Weakness: CWE-79
Description
DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to versions 9.13.10 and 10.2.0, a module could install with richtext in its description field which could contain scripts that will run for user in the Persona Bar. Versions 9.13.10 and 10.2.0 contain a fix for the issue.
Affected products
- DotNetNuke CMS Fixed in 9.1.1: before 9.13.10; from 10.0.0 before 10.2.0 — fixed in 10.2.0, 9.13.10
How to fix
Upgrade to a fixed version: DotNetNuke CMS Fixed in 9.1.1 10.2.0, 9.13.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-24833 or the next vulnerability affects your stack