What’s Vulnerable › Vulnerabilities
CVE-2026-24835: Podman Desktop Extension System Vulnerable to Authentication Bypass
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-28 · updated 2026-06-17
- Weakness: CWE-285
Description
Podman Desktop is a graphical tool for developing on containers and Kubernetes. A critical authentication bypass vulnerability in Podman Desktop prior to version 1.25.1 allows any extension to completely circumvent permission checks and gain unauthorized access to all authentication sessions. The `isAccessAllowed()` function unconditionally returns `true`, enabling malicious extensions to impersonate any user, hijack authentication sessions, and access sensitive resources without authorization. This vulnerability affects all versions of Podman Desktop. Version 1.25.1 contains a patch for the issue.
Affected products
- podman-desktop: before 1.25.1 — fixed in 1.25.1
How to fix
Upgrade to a fixed version: podman-desktop 1.25.1. Check the vendor advisory for mitigations.
References
- https://drive.google.com/file/d/1ib4RG34mGHDlXeyib8L2j9L5rEDxuDM5/view?usp=sharing
- https://github.com/podman-desktop/podman-desktop/security/advisories/GHSA-v3fx-qg34-6g9m
Get alerted when CVE-2026-24835 or the next vulnerability affects your stack