What’s Vulnerable › Vulnerabilities
CVE-2026-24844: melange pipeline working-directory could allow command injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-04 · updated 2026-06-17
- Weakness: CWE-78
Description
melange allows users to build apk packages using declarative pipelines. From version 0.3.0 to before 0.40.3, an attacker who can provide build input values, but not modify pipeline definitions, could execute arbitrary shell commands if the pipeline uses ${{vars.*}} or ${{inputs.*}} substitutions in working-directory. The field is embedded into shell scripts without proper quote escaping. This issue has been patched in version 0.40.3.
Affected products
- chainguard-dev melange: from 0.3.0 through 0.40.5
References
- https://github.com/chainguard-dev/melange/commit/e51ca30cfb63178f5a86997d23d3fff0359fa6c8
- https://github.com/chainguard-dev/melange/security/advisories/GHSA-vqqr-rmpc-hhg2
Get alerted when CVE-2026-24844 or the next vulnerability affects your stack