What’s Vulnerable › Vulnerabilities
CVE-2026-24851: OpenFGA Improper Policy Enforcement
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-06 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.8.5 to v1.11.2 ( openfga-0.2.22<= Helm chart <= openfga-0.2.51, v.1.8.5 <= docker <= v.1.11.2) are vulnerable to improper policy enforcement when certain Check calls are executed. The vulnerability requires a model that has a a relation directly assignable by a type bound public access and assignable by type bound non-public access, a tuple assigned for the relation that is a type bound public access, a tuple assigned for the same object with the same relation that is not type bound public access, and a tuple assigned for a different object that has an object ID lexicographically larger with the same user and relation which is not type bound public access. This vulnerability is fixed in v1.11.3.
Affected products
- openfga Helm Charts: from 0.2.22 before 0.2.51 — fixed in 0.2.51
- openfga: from 1.8.5 before 1.11.3 — fixed in 1.11.3
How to fix
Upgrade to a fixed version: openfga Helm Charts 0.2.51; openfga 1.11.3. Check the vendor advisory for mitigations.
References
- https://github.com/openfga/openfga/releases/tag/v1.11.3
- https://github.com/openfga/openfga/security/advisories/GHSA-jq9f-gm9w-rwm9
Get alerted when CVE-2026-24851 or the next vulnerability affects your stack