What’s Vulnerable › Vulnerabilities

CVE-2026-24880: Apache Tomcat: Request smuggling via invalid chunk extension

Description

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache Tomcat via invalid chunk extension. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M1 through 10.1.52, from 9.0.0.M1 through 9.0.115, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other, unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.20, 10.1.52 or 9.0.116, which fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Tomcat 9.0.116, 10.1.53, 11.0.20. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-24880 or the next vulnerability affects your stack