What’s Vulnerable › Vulnerabilities
CVE-2026-24881
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-27 · updated 2026-07-15
- Weakness: CWE-121
Description
In GnuPG before 2.5.17, a crafted CMS (S/MIME) EnvelopedData message carrying an oversized wrapped session key can cause a stack-based buffer overflow in gpg-agent during PKDECRYPT--kem=CMS handling. This can easily be leveraged for denial of service; however, there is also memory corruption that could lead to remote code execution.
Affected products
How to fix
Upgrade to a fixed version: GnuPG 2.5.17; Gpg4Win 5.0.1. Check the vendor advisory for mitigations.
References
- https://dev.gnupg.org/T8044
- https://www.openwall.com/lists/oss-security/2026/01/27/8
- https://access.redhat.com/security/cve/CVE-2026-24881
- https://bugzilla.redhat.com/show_bug.cgi?id=2433480
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-24881.json
Get alerted when CVE-2026-24881 or the next vulnerability affects your stack